[MBDyn-users] Mac OS X 10.8 compilation

Pierangelo Masarati masarati at aero.polimi.it
Tue Apr 2 01:02:30 CEST 2013


> Hi guys:
>
> Has anybody successfully compiled MBDyn 1.5.* on Mac OS X 10.8 with
> modules?
>
> I have got the following errors when trying to do it:
>
> ---------------------------------------
> /bin/sh ../libtool --mode=link /opt/packages/gcc-4.7.2/bin/g++-4.7
> -I/opt/packages/autotools/include/ -fPIC -L/opt/packages/autotools/lib
> -flat_namespace -shared  -L/opt/packages/autotools/lib
> -L/opt/packages/gcc-4.7.2/lib/gcc/x86_64-apple-darwin12.2.0/4.7.2
> -L/opt/packages/gcc-4.7.2/lib/gcc/x86_64-apple-darwin12.2.0/4.7.2/../../..
> -lgfortran -lquadmath -lm -rpath /usr/local/mbdyn/libexec -o
> libmodule-cudem.la cudem.lo module-cudem.lo -L/usr/local/cuda/lib64 -lhdf5
> -lcudart -lcuda
> libtool: link: can not build a shared library
> libtool: link: See the libtool documentation for more information.
> libtool: link: Fatal configuration error.
> make[2]: *** [libmodule-cudem.la] Error 1
> ---------------------------------------
>
> This error is not related to my specific module. I was able to reproduce
> this with other modules included in MBDyn.
>
> Any suggestions on this?

Hi Tingnan,

that problem was recently noticed by Andrea Zanoni, who also found a
workaround described in a note here
<http://www.mbdyn.org/documentation/faq.html#HOW_CAN_I_BUILD_RUN_TIME_LOADABLE_MODULES>.

The problem seems to be specific of that version of OSX.  Please let us
know if you succeed in fixing it.

Cheers, p.

-- 
Pierangelo Masarati
Associate Professor
Dipartimento di Scienze e Tecnologie Aerospaziali
Politecnico di Milano



More information about the MBDyn-users mailing list