[MBDyn-users] Modal element error

masarati at aero.polimi.it masarati at aero.polimi.it
Tue Aug 18 17:22:46 CEST 2009


> Hello,
>
> I am trying to use modal elements on a beam (one side embedded, one side
> with a normal force). You can find enclosed the input files.
> Unfortunatly, the simulation abord with a error a don't understand :
> "Initial assembly iterations reached maximum number 1; aborting ...
> An error occurred during the execution of MBDyn; aborting ..."
> How can I solve this type of error?

This error indicates that the "initial assembly" of the model failed. 
There may be a number of reasons for this failure.  Usually, it indicates
that the model, as defined in the input file, violates some of the
constraints.

In this case, first of all enable the output of the assembly procedure, by
adding the statements

        output: iterations;
        output: residual;

in the "initial value" block.  This results in

...
Residual(0):
Eq         1:                    0 StructNode(1): position constraint Px
Eq         2:                    0 StructNode(1): position constraint Py
...
Eq        78:                    0 Modal(3): modal equilibrium equation f(3)
Eq        79:                 49.5 Modal(3): StructNode(2) position
constraint Px
Eq        80:                    0 Modal(3): StructNode(2) position
constraint Py
...
Eq        90:                    0 Modal(3): StructNode(2) angular
velocity constraint wz
Eq        91:                -49.5 Modal(3): StructNode(4) position
constraint Px
Eq        92:                    0 Modal(3): StructNode(4) position
constraint Py
...

This means that the location of the FEM and the multibody interface nodes
corresponding to the multibody nodes (2) and (4) of the modal element (3)
are not coincident.  You should fix this inconsistency before proceeding
any further.

Hope this helps.

Cheers, p.



More information about the MBDyn-users mailing list